Ivans Distribution Platform is currently experiencing and issue with submissions

Incident Report for Ivans

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 08:05 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 07:59 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2026 - 07:56 CDT

Investigating

Submissions are currently impacted, causing responses from markets to be not be sent to the integrators. We are investigating the root cause.
Posted Apr 10, 2026 - 07:50 CDT
This incident affected: Ivans Distribution Platform (Submissions).