Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 17, 2024 - 00:00 CST
Scheduled
Ivans Exchange and Ivans Bookroll will be undergoing updates on November 17, 2024. These updates are currently in our staging envrionment. After the update, please ensure your transactions are processing as expected.
Posted Nov 08, 2024 - 07:30 CST
This scheduled maintenance affected: Ivans Download and Exchange (Ivans Exchange Website, Ivans Exchange APIs) and Ivans Bookroll.